Keras/tensorflow version conflicts

I am getting the following error when submitting my code

command not exited correctly: 1
ERROR: Cannot install -r /context/code/requirements.txt (line 10) and keras==3.0.2 because these package versions have conflicting dependencies.
ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/topics/dependency-resolution/#dealing-with-dependency-conflicts

Is there a way to modify the requirements.txt file to fix this?

Sorry for the very late answer.
I am still answering for other people that could have the same issue.


Sometimes the very lastest version of some libraries are not yet available on the GPU runner.

To manually specify version, users can write a comment with the constraint next to the import: