Error in Submission even though it passes the test

I get the following error… I have a hard time understanding what is going on behind the hood because the test passes, on it gives me a dataframe when I run it locally…

Traceback (most recent call last):
File “/runner/executor.py”, line 206, in cli
ensure_dataframe(prediction, “prediction”)
File “/runner/executor.py”, line 90, in ensure_dataframe
raise ValueError(f"{name} must be a dataframe")
ValueError: prediction must be a dataframe

Any ideas? @enzo

thanks!

I should print more, but the error mean that the infer function didn’t returned a dataframe.
Maybe you forgot a return, or branched and forgot to return the dataframe, or even returned a series instead.

If you give me your Run ID, I could take a look to see if I can know more.

Thank you for the quick reply!

The id is #4817. It is strange because I have not changed the code in inference at all, and it failed at the first moon 268…

Same thing happened in my subsequent submission: #4826

I ran the exact same notebook used for the submission locally, and it does return a dataframe for moon 268, where the issue occurs. I suspect the issue is not on my side…

Sorry the runner had a bug that was quickly resolved.
Just re-run your code.

Okay, thanks! I will try that.

I suppose it won;t count as new submissions.

Submissions are your code.
Runs are running your code.

Here only running it failed because of us, so its not a new submission if that what you was afraid of.